Network Degradation in Europe

Major incident Europe Global Network and Backbone ADC-as-a-Service Cloud Load Balancing
46 minutes, 46 seconds

Updates

Resolved

This incident is resolved pending hardware replacement. All traffic is routing normally at this time. If you are encountering any issues, please open a support case at https://support.totaluptime.com

June 28, 2020 · 00:29 UTC
Monitoring

All traffic is routing normally within the region. Engineers are currently working to replace failed hardware at this time.

June 28, 2020 · 00:13 UTC
Update

Engineers have found the root cause of the issue and are working to remedy it at this time.

June 27, 2020 · 23:54 UTC
Issue

We are currently investigating reports of degraded network performance including additional latency and packet loss across portions of our network. Engineers are actively investigating the issue at this time. We will post updates here as they become available. Thank you for your patience as we work to restore service to normal levels as quickly as possible.

June 27, 2020 · 23:43 UTC

← Back