Network Degradation

Major incident Europe Global Network and Backbone
44 minutes

Updates

Resolved

All service has returned to normal at this time. If you are continuing to experience any issues, please create a ticket at https://support.totaluptime.com

May 3, 2020 · 21:05 UTC
Investigating

Engineers have isolated the issue to a recently deployed hardware node in the Amsterdam POP. We are currently removing this device from service. Traffic levels and response time should return to normal shortly.

May 3, 2020 · 20:31 UTC
Issue

We are currently investigating reports of degraded network performance including additional latency and packet loss across portions of our network in Europe. Engineers are actively investigating the issue at this time. We will post updates here as they become available. Thank you for your patience as we work to restore service to normal levels as quickly as possible.

May 3, 2020 · 20:21 UTC