NA-East Network Degradation

Minor incident North America - East Global Network and Backbone
53 minutes

Updates

Resolved

Traffic has resumed in the region and all services are operating normally.

March 18, 2020 · 03:26 UTC
Monitoring

Engineers have resolved the backbone issues within the NA-E region. We are currently waiting for all false alerts to clear before restoring traffic. We anticipate this to be completed within the next 30 minutes. In the interim, all traffic continues to route through alternate POPs to ensure uninterrupted service.

March 18, 2020 · 02:57 UTC
Investigating

We are encountering backbone connectivity issues within the NA-East region. Automation shifted traffic away from this region while engineers investigate further. Unfortunately customers may receive alerts from the NA-E region during this time.

March 18, 2020 · 02:49 UTC
Issue

We are currently investigating reports of degraded network performance including additional latency and packet loss across portions of our NA-East network. Engineers are actively investigating the issue at this time. We will post updates here as they become available. Thank you for your patience as we work to restore service to normal levels as quickly as possible.

March 18, 2020 · 02:34 UTC